HR platform: Minimum software requirements

Overview

Employment Hero is a web-based SaaS (software as a service) application, which you can access through a supported web browser and/or dedicated mobile application.

Web browser requirements
Browser Requirements
Google Chrome Most up-to-date and recent version.
Internet Explorer Most up-to-date and recent version.
Firefox Most up-to-date and recent version.
Safari Most up-to-date and recent version.

Warning

Users may experience issues with Employment Hero if they are running an outdated version of a browser. To ensure you have the best experience, update your browser to the latest version.

Employment Hero does not support any beta versions or alternative open source builds of these browsers.

Important

Ensure you have enabled cookies and JavaScript within your browser. If you have not enabled them, you will need to accept their usage upon your first login.

Mobile application requirements
Browser Requirements
iOS iOS 11 or above.
Android Android 7.0 or above.1

Comments

0 comments

Article is closed for comments.